Accueil | Recherche | News | Articles | Téléchargement | Forums | Commentaires | A propos
       
 
Hébergement mutualisé chez OVH

  Recherche
  Catégories

• Apache
• PHP
• Système
• Tomcat

  Webmestres

   Page de démarrage
    Ajouter aux favoris
    Les news sur
    votre site

  Dernières versions

Apache 2.2.8
Apache 2.0.63
Apache 1.3.41
PHP 4.4.7
PHP 5.2.4
MySQL 5.0.45
MySQL 4.1.22
MySQL 4.0.27
phpMyAdmin 2.11.0
Tomcat 5.5.20
Tomcat 4.1.34
Tomcat 3.3.2

  Derniers modules

mod_auth_bsd 1.2
mod_design 0.4
mod_ometer 1.2.0
mod_epp 1.0
mod_mono 0.3.6

  Statistiques

Apache
PHP  

  Documentation

Apache 1.3
Apache 1.3 VF
Apache 2.0
Tomcat 3
Tomcat 4
PHP
MySQL

  Liens

Apache
Apache Project
Jakarta Project
Liste des bugs
Apache Today
Apache Week
Apache Reference
Apache@Slashdot
Reference cards

PHP/MySQL
PHP
MySQL
PHP Index
PHP Team

Les nouvelles

02/10  BigApache 1.05
02/10  GĂ©rer les fichiers .htacess avec PHP
25/08  PHP 4.3.3
21/07  Apache 1.3.28
09/07  Apache 2.0.47
07/07  Apache 2.0.46
30/06  Mise Ă  jour des forums
30/05  PHP 4.3.2
12/05  phpMyAdmin 2.5.0
16/04  Test de performance Apache + PHP

Prec. 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  Suiv.

 
BigApache 1.05
Posté le 02/10/2003 @ 21:05:23
Source : PHP Index

Vu sur PHPIndex.com :
"Méconnu par rapport à l’incontournable EasyPhp, le package BigApache nous offre divers dispositifs avantageux. Ce package permet de déployer un serveur HTTP complet rapidement. Il contient les composants : PHP, MySQL, Perl, Python,ASP::Apache, JBoss et Tomcat.

Ce freeware fonctionne à la fois sous Unix et Windows, avantage que n’offre pas easyPhp. L’utilisation de BigApache peut être d’ordre commercial ou non. On n’oublie pas la possibilité d’envoyer des mails grâce à l’implantation d’un serveur MAIL Mercury associé aux protocoles POP, SMTP, IMAP, SSL et d’un antispam.

Comme Easyphp, le package est associé à un installeur qui facilite l'opération.

La dernière version (v1.05) date du 3 juin 2003."

En résumé, un bon concurrent de EasyPHP à tester d'urgence !
Rendez-vous sur le site officiel.

 
GĂ©rer les fichiers .htacess avec PHP
Posté le 02/10/2003 @ 20:59:59
Source : Nexen.net

Vu sur nexen.net :
"PHPAccess résoud avec élégance vos problèmes de .htaccess. Lorsque vous voulez protéger un dossier avec le fichier .htaccess d'apache, plus besoin de courir sur le serveur pour configurer convenablement ces fichiers. PHPaccess le fait pour vous, et met en place tous les éléments nécessaires.
PHPAccess est une application GPL gratuite."

Rendez-vous sur le site officiel.

 
PHP 4.3.3
Posté le 25/08/2003 @ 20:29:03
Source : PHP Index

Vu sur PHP Index :
"La version 4.3.3 de PHP vient d'être publiée. Cette version apporte, en particulier, les évolutions suivantes :

• Correction d'un centaine de bugs
• Amélioration du support NSAPI SAPI
• Amélioration du support IMAP et InterBase
• Mise à jour des librairies Expat (1.95.6), PCRE (4.3) et GD (2.0.15)
• Amélioration de la sécurité (buffer overflow, etc.)"

Pour plus de détails, vous pouvez consulter l'historique des changements ici.
Pour télécharger, c'est ici.

 
Apache 1.3.28
Posté le 21/07/2003 @ 17:10:21
Source : Apache Group

Une nouvelle version d'Apache 1.3 est disponible ! La version 1.3.28 corrige principalement 3 failles de sécurité majeures :
- [CAN-2003-0460] : correction du programme rotagelog sous Win32 et OS/2 afin que celui-ci ignore certains caractères de contrôle reçus d'Apache. Ceux-ci pouvaient faire planter et donc stopper la journalisation.
- VU#379828 : le processus serveur pouvait crasher s'il rentrait dans une boucle infinie provoquée par de trop nombreuses redirections internes ou des sous-requêtes imbriquées
- Correction du manque de descripteurs de fichiers constatés dans certains processus fils, par exemple les scripts CGI.

Pour le détail complet des modifications apportées par Apache 1.3.28, rendez-vous ici.
Pour télécharger Apache 1.3.28, rendez-vous ici.

 
Apache 2.0.47
Posté le 09/07/2003 @ 20:13:49

Rapide comme l'éclair, l'Apache Group nous crédite d'une nouvelle version d'Apache 2, la 2.0.47.

Quoi de neuf depuis la version précédente vieille de 2 jours ?
Comme d'habitude, corrections de failles de sécurité et de bugs :
- CAN-2003-0192 : Certain sequences of per-directory renegotiations and the SSLCipherSuite directive being used to upgrade from a weak ciphersuite to a strong one could result in the weak ciphersuite being used in place of the strong one
- CAN-2003-0253 : Certain errors returned by accept() on rarely accessed ports could cause temporal denial of service, due to a bug in the prefork MPM
- CAN-2003-0254 : Denial of service was caused when target host is IPv6 but ftp proxy server can't create IPv6 socket
- VU#379828 : The server would crash when going into an infinite loop due to too many subsequent internal redirects and nested subrequests

Pour plus de détails, rendez-vous sur la page de l'annonce officielle ici.
Pour télécharger Apache 2.0.47, rendez-vous ici.

 
Apache 2.0.46
Posté le 07/07/2003 @ 20:15:15

La nouvelle version d'Apache 2, estampillée 2.0.46, est disponible.
Celle-ci corrige bugs majeurs de sécurité :
- CAN-2003-0245 : Vulnerability in the apr_psprintf function in the Apache Portable Runtime (APR) library for Apache 2.0.37 through 2.0.45 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via long strings, as demonstrated using XML objects to mod_dav, and possibly other vectors.
- CAN-2003-0189 : The authentication module for Apache 2.0.40 through 2.0.45 on Unix does not properly handle threads safely when using the crypt_r or crypt functions, which allows remote attackers to cause a denial of service (failed Basic authentication with valid usernames and passwords) when a threaded MPM is used.

La version 2.0.46 corrige plusieurs autre bugs mineurs et ajoute quelques fonctionnalités, mineures elles aussi. Pour plus de détails, rendez-vous sur la page de l'annonce officielle ici.
Pour télécharger Apache 2.0.46, rendez-vous ici.

 
Mise Ă  jour des forums
Posté le 30/06/2003 @ 20:14:21

Tout d'abord toutes mes excuses pour l'interruption de service des forums...
C'était pour la bonne cause puisque les forums d'Apache France ont été mis à jour vers la version 3.4.4 de Phorum.

L'une des principales raisons était de disposer d'une fonction d'identification "au cas où", ainsi que de proposer une interface simple aux modérateurs. A ce propos, je vous annonce officiellement que vos deux modérateurs sont Gandalf et DarkMaxou.

N'hésitez pas à m'informer de tout problème relatif au "phorum", et encore merci à vous tous qui faites vivre les forums d'Apache France !

Michel, votre webmaster

 
PHP 4.3.2
Posté le 30/05/2003 @ 18:37:58
Source : PHP Index

Une nouvelle version de PHP estampillée 4.3.2 est disponible.
Celle-ci est d'avantage une version de maintenance mais qui contient malgré tout certaines améliorations notables.
Pour plus de détails, rendez-vous ici.

Télécharger PHP 4.3.2

 
phpMyAdmin 2.5.0
Posté le 12/05/2003 @ 23:25:29
Source : PHP Index

Vu sur PHPIndex :
"La version 2.5.0 finale de phpMyAdmin est désormais disponible.

Au programme, un total de 28 Ă©volutions comme :
- popup pour effectuer vos requĂŞtes (lien bas de page colonne de gauche),
- un historique des requĂŞtes SQL,
- la possibilité d'afficher des images contenues dans des champs BLOB,
- une nouvelle page d'exportation des données,
- de plus amples informations lors de l'affichage de la structure d'une table,
- une possibilité d'imprimer une vue de la base de données.

Bref, pas de révolution mais des fonctionnalités fort utiles qui devrait nous simplifier la vie.

Vous y trouverez des améliorations comme une meilleure sécurité lors de l'importation de données, une aide dans la réalisation des requêtes et bien d'autres fixes.

A noter que cette version ne fonctionne pas avec MySQL 4.1 mais les versions futures la supporteront.

Je vous engage Ă  vous reporter au changelog et Ă  la page d'accueil du site pour retrouver la longue liste des modifications."

Le site officiel

Télécharger phpMyAdmin

 
Test de performance Apache + PHP
Posté le 16/04/2003 @ 20:02:26
Source : Nexen.net

Vu sur le site de Nexen :
"Ian Holsman a réalisé des tests de vitesse, en utilisant PHP 4.3.1 et Apache 2.0.44. Ces tests permettent de comparer les vitesses relatives des différentes configurations et API possibles pour PHP, avec Apache 2.0.45."

Le site : http://webperf.org/results/php-versions.html.

NDW : ce bench est d'une certaine façon à prendre avec des pincettes vu le manque de détails, mais il semblerait qu'Apache 1.3 reste LA plate-forme de choix pour l'intégration avec PHP. Cela explique certainement que les hébergeurs ne se risquent pas à une migration.

 
Prec. 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  Suiv.
Posts récents des forums
 

• Tracer les logs d'Apache (2.2.15) dans Configuration
• Problem with my server or with the software? dans GĂ©nĂ©ral
• Connexion en 4g dans Configuration
• Problème d'affichage via reverse proxy Apache dans GĂ©nĂ©ral
• Modification de l'entĂŞte http dans Configuration
• erreur liĂ© Ă  proxy fcgi dans Configuration
• Vhost : mixer un vhost 80 et un vhost 443 dans Configuration
• Connexion .htaccess .htpasswd pour plusieurs utilisateurs dans Configuration
• plusieurs sites en local dans Configuration
• probleme compilation apache dans Annonces, mode d'emploi, règles Ă  suivre

Les Forums

 

Copyright © 2001-2004 M.Geldenhuys - Tous droits réservés